Si tienes esta tarjeta gráfica, actualiza sus drivers o estarás en grave peligro

Si tienes esta tarjeta gráfica, actualiza sus drivers o estarás en grave peligro

Rubén Velasco

Los drivers son una serie de programas y librerías necesarias para que el sistema operativo, ya sea Windows, macOS, o Linux, pueda detectar cada uno de los componentes del ordenador y hacer uso de ellos. Cuando instalamos Windows de cero, el sistema instala unos controladores genéricos, diseñados para que funcionen los componentes básicos, pero poco más. Sin embargo, si queremos sacar todo el rendimiento posible al ordenador es necesario instalar a mano los controladores del fabricante, siendo uno de los más importantes el de la tarjeta gráfica.

No solo es importante instalar los drivers de la tarjeta gráfica si queremos que esta pueda funcionar a pleno rendimiento, sino que también es vital mantenerlos actualizados. Con cada actualización, el fabricante (en este caso, NVIDIA o AMD) suelen corregir errores, mejorar el rendimiento general de la tarjeta y, de paso, optimizar su funcionamiento para rendir al máximo en los últimos juegos que llegan al mercado. Sin embargo, en ocasiones, las actualizaciones no se centran en esto, sino en corregir vulnerabilidades que están poniendo en peligro nuestro PC.

NVIDIA corrige vulnerabilidades graves: actualiza ya

La última versión de los drivers de NVIDIA no solo ha traído algunas mejoras y correcciones al controlador, sino que también se ha centrado en corregir varias vulnerabilidades muy graves que estaban poniendo en peligro la seguridad de los usuarios. En total, son 29 los fallos que se han corregido con la última versión de los controladores, dos de ellos además muy críticos con puntuaciones de 8.8 y 8.5 sobre 10 de peligrosidad:

  • CVE-2022-34669: vulnerabilidad que permite a un atacante local tener control sobre el driver de la gráfica y modificar sus archivos para conseguir ejecutar código en el sistema, ganar privilegios e incluso llevar a cabo ataques DoS.
  • CVE-2022-34671: fallo que se puede explotar de forma remota y permite a un atacante ejecutar código remoto, ganar privilegios, robar información sensible de la memoria e incluso llevar a cabo ataques DoS.

Estas dos vulnerabilidades son las más críticas y peligrosas que nos encontramos, aunque también encontramos otros fallos de seguridad que permiten llevar a cabo ataques complejos de red, ganar privilegios con malware y mucho más. Esto es posible debido a que los drivers son programas que se ejecutan con el mayor rango de privilegios en el sistema, SYSTEM (o root, en el caso de Linux) y, por tanto, cualquier pequeño fallo de seguridad puede tener graves consecuencias.

Actualizar los drivers cuanto antes

Todas las versiones anteriores a las últimas son vulnerables a estos fallos de seguridad. Por tanto, es vital actualizar los controladores cuanto antes si no queremos tener problemas. En el caso de Windows, por ejemplo, para unas tarjetas gráficas de la serie GeForce, tenemos que asegurarnos de que la versión instalada es igual, o posterior, a las siguientes:

  • Windows (la más avanzada): versión 526.98 o superior.
  • Windows 10 y Windows 11: versión 474.04 o posterior.
  • Windows 7 y 8.1: versión 474.06 o superior.

NVIDIA Driver 526.98

Igualmente, si tenemos gráficas avanzadas como Quadro, Studio o Tesla, es necesario asegurarnos de tener la última versión en el PC. Y, en el caso de Linux, igualmente es necesario tener las últimas versiones instaladas ya que estos fallos de seguridad también ponen en peligro a Linux.

Cómo actualizar

Las nuevas versiones de los drivers las tenemos disponibles en el centro de descargas de NVIDIA. Simplemente tendremos que buscar el modelo de nuestra tarjeta, seleccionar nuestro sistema operativo y el idioma, y bajar el paquete que nos ofrecerá la web. Una vez bajado, lo ejecutamos con doble clic y comenzamos con la instalación.

Si ya tenemos los drivers instalados, y, sobre todo, si tenemos el GeForce Experience, también podemos instalar estos controladores desde el programa. Lo importante es asegurarnos de tener la versión 526.98, o cualquiera superior, para poder estar seguros.

Fuente > NVIDIA

¡Sé el primero en comentar!