PuTTY, ¿es mejor la versión de 64 bits, o la de 32 bits?

Cuando nos vamos a conectar de forma remota a un ordenador tenemos varias formas de hacerlo. La primera de ellas es mediante una conexión de escritorio remoto, ya sea a través del protocolo RDP de Microsoft, o usando otras herramientas como AnyDesk o TeamViewer. Sin embargo, también podemos recurrir a otro tipo de programas más avanzados que nos permiten establecer conexiones seguras a través del protocolo SSH, como es el caso de PuTTY.

PuTTY es un programa, totalmente gratuito y de código abierto, que nos permite establecer conexiones remotas, a través de SSH, desde Windows. Gracias a este programa vamos a poder gestionar nuestras conexiones de forma muy sencilla y conectarnos de forma remota a cualquier servidor, o equipo, que permita conexiones a través de este protocolo de manera que podamos trabajar, mediante comandos, como si estuviéramos sentados delante de él.

Como con cualquier programa, a la hora de descargar PuTTY es vital bajar la última versión, ya que de esta forma no solo nos aseguramos de que las conexiones son seguras, no hay fallos, y usamos las últimas versiones de los protocolos. Sin embargo, a la hora de bajar este programa en Windows nos pueden surgir algunas dudas. ¿qué edición es mejor?

Bajar PuTTY de 32 o de 64 bits

Como suele ocurrir con todos los programas, la versión correcta es la que corresponda con nuestro sistema operativo. Así podremos aprovechar mejor las características del mismo. Sin embargo, si no sabemos exactamente si estamos usando un sistema de 32 o de 64 bits, entonces lo mejor será elegir la de 32 bits, ya que será la que funcione por igual en ambas ediciones del sistema operativo, y así no tendremos problemas.

Sin embargo, si estamos seguros de usar un sistema operativo de 64 bits, entonces lo mejor será elegir directamente la versión de 64 bits. Esta versión se ejecutará más rápido (concretamente, las tareas de criptografía se ejecutan más rápido) y nos permitirá configurar los enlaces seguros en menos tiempo. En cambio, esta versión consumirá algo más de memoria RAM al tener que procesar instrucciones de memoria más largas.

Por último, si es necesario utilizar dispositivos externos para usar la autenticación GSSAPI, es posible que la DLL solo esté disponible para 32 o para 64 bits, dependiendo del dispositivo. Y, claramente, en ese caso tendremos que elegir la versión que sea compatible con la librería de nuestro sistema.

Descargar el programa

Una vez que sepamos la versión que más se adapta a nuestras necesidades, entonces lo único que tenemos que hacer es ir al siguiente enlace y descargar desde allí la última versión disponible. Actualmente, PuTTY se llega por la versión 0.76, y la versión de 64 bits hizo su debut con la llegada de la 0.68, por lo que no tendremos problemas para encontrarla, siempre que busquemos la versión más reciente disponible.

En caso de querer conectarnos desde una tablet, o un ordenador con procesador ARM, tendremos que bajar la versión correspondiente a esta arquitectura desde la web del programa. De lo contrario, estos procesadores no son capaces de trabajar con las versiones ni de 32 bits ni de 64 bits estándar.

¡Sé el primero en comentar!