Si tienes un portátil Intel, debes actualizar sus drivers cuanto antes

Si tienes un portátil Intel, debes actualizar sus drivers cuanto antes

Rubén Velasco

Los drivers son una de las partes más importantes de nuestro ordenador. Estos pequeños programas son los encargados de hacer que el sistema operativo identifique y sea capaz de usar el hardware de nuestro PC. Mantener los drivers siempre actualizados es muy importante ya que no solo nos permite sacarle el máximo partido al hardware y aprovechar todo su rendimiento, sino que también nos ayuda a mantener nuestro ordenador seguro y protegido. Especialmente cuando se descubren vulnerabilidades en estos drivers que debemos solucionar cuanto antes, como le ha ocurrido a Intel.

Los drivers de Intel no solo se encargan de controlar el chipset de los ordenadores de este fabricante, sino que también son muy utilizados en portátiles que cuentan con gráfica integrada (iGPU) en el procesador.

Hace unas horas, junto a los parches de seguridad de Microsoft, Intel lanzaba una actualización para sus propios drivers. Esta podría ser una actualización más, de mantenimiento, sin embargo, corrige 6 vulnerabilidades importantes que pueden poner en peligro tu ordenador. Por ello, si tu ordenador es Intel, debes instalar esta nueva versión cuanto antes.

Vulnerabilidades corregidas en la última versión de los drivers de Intel

En total, Intel ha corregido 6 vulnerabilidades en la nueva versión de sus drivers. Una de estas vulnerabilidades ha sido considerada como de peligrosidad alta, 4 de ellas como de peligrosidad media y una como de peligrosidad baja.

La más importante es la vulnerabilidad de peligrosidad alta. Este fallo de seguridad se encuentra en el componente Intel VTune Amplifier para Windows, y, como afirma la compañía, ha sido detectada por sus propios trabajadores, por lo que no ha puesto en peligro a los usuarios (aún).

Este fallo de seguridad puede permitir a cualquier usuario con acceso local al sistema ganar privilegios dentro de él hasta conseguir el nivel SYSTEM.

Los demás fallos de seguridad se encuentran en otros componentes de los drivers, como en los controladores gráficos Intel Processor Graphics de este fabricante. Y todos ellos están relacionados con la divulgación de información confidencial de los usuarios.

Intel Graphics Control Panel

Cómo proteger nuestro ordenador de estas vulnerabilidades

En el caso de la vulnerabilidad grave, Intel recomienda a los usuarios instalar la Update 8 de VTune para solucionar este fallo de seguridad. Esta actualización se puede conseguir desde el siguiente enlace.

Para protegernos del resto de las vulnerabilidades es necesario instalar las últimas versiones de los drivers gráficos de este fabricante. En el caso de Windows, por ejemplo, debemos asegurarnos de tener instalada una versión igual o superior de Intel Processor Graphics a las siguientes:

  • 26.20.100.7209
  • 15.45.x.5077
  • 15.40.x.5107
  • 15.36.x.5117
  • 15.33.x.5122

Estos fallos de seguridad también afectan a los usuarios de Linux. Por lo tanto, si utilizamos este sistema operativo y queremos protegernos debemos asegurarnos de estar usando una versión del Kernel igual o superior a las siguientes (versiones lanzadas el pasado 7 de enero de 2020):

  • Mainline: 5.5-rc6
  • Stable: 5.4.12
  • LTS
    • 4.19.96
    • 4.14.165
    • 4.9.210
    • 4.4.210

Procesadores Intel afectados

El fabricante asegura que estos fallos de seguridad afectan a la mayoría de los modelos de sus procesadores:

  • Desde la tercera hasta décima generación de Intel Core.
  • Intel Xeon E3, desde la v2 hasta la v6, además de los modelos E-2100 y 2-2200.
  • Intel Atom A, E, X y Z.
  • Intel Celeron.

Eso sí, Intel nos recuerda que no todos los procesadores tienen la mitigación de las vulnerabilidades completas. Algunos chips, como Ivy Bridge, Bay Trail y Haswell tienen un parche temporal, y aún tardará en llegar una mitigación completa para estas vulnerabilidades. Aun así, recomendamos encarecidamente actualizar los drivers.