Habilita Java y Silverlight en Firefox 52 con este sencillo truco

Escrito por Rubén Velasco
Navegadores
6

Los plugins NPAPI (Netscape Plugin Application Programming Interface) han sido utilizados en los navegadores web durante muchos años, sin embargo, actualmente estos complementos están obsoletos, desactualizados y suponen un grave peligro para la seguridad de los usuarios. Como los desarrolladores no terminan de actualizar a nuevos protocolos y siguen utilizando estas arcaicas tecnologías, finalmente han sido los navegadores quienes han tenido que dar el paso y bloquear estos plugins para preservar la seguridad de los usuarios, tal como acaba de hacer Firefox 52.

Hace 3 días, Mozilla publicaba el nuevo Firefox 52, la nueva versión del navegador web que llega con importantes cambios y mejoras que siguen dando, poco a poco, forma al futuro del navegador. Esta nueva versión, además, ha sido la primera en bloquear por defecto el uso de los plugins NPAPI, excepto Flash, haciendo que todas las páginas web que utilizaran, por ejemplo, Java o Silverlight, dejaran de funcionar.

Por suerte, aún es posible seguir utilizando, temporalmente, este tipo de contenido en el navegador.

Cómo usar Java, Silverlight y otros plugins NPAPI en Firefox 52

Para habilitar estos plugins en esta versión del navegador, lo único que debemos hacer es abrir el apartado de configuración “about:config” y buscar en él la entrada:

  • plugin.load_flash_only

Hacemos doble clic sobre ella para cambiar su valor a “false” y reiniciamos nuestro navegador.

Firefox 52 - Habilitar plugins NPAPI

Cuando vuelva a cargar el navegador, podremos ver cómo estos plugins vuelven a estar activos en el navegador (entrando en about:addons) y, si los tenemos correctamente instalados en nuestro ordenador nos permitirá seguir cargando este contenido.

Una solución a corto plazo. Los plugins NPAPI tienen sus días contados

Como hemos dicho, este truco funcionará en Firefox 52 y nos permitirá seguir utilizando estos complementos durante el ciclo de vida de esta versión. Sin embargo, cuando se lance el próximo Firefox 53, este truco dejará de funcionar y los plugins NPAPI dejarán de ser compatibles, de ninguna manera, con el navegador.

Por suerte, Firefox 52 tiene una versión de soporte extendido ESR que sí será compatible con estos plugins, al menos, hasta la próxima ESR. Por ello, los compañeros de RedesZone nos explican cómo podemos habilitar el uso de los plugins NPAPI en Firefox 52 cambiando la rama de desarrollo a la rama ESR. Google Chrome, por otro lado, ya tiene depreciados estos plugins desde 2014.

De esta forma, en lugar de perderlos definitivamente cuando se lance la próxima actualización del navegador, en realidad funcionarán, al menos, hasta la llegada de Firefox 59, a finales de este año, que se actualice la versión ESR.

Adobe Flash Player, el NPAPI que se resiste a desaparecer

Cuando decimos que los navegadores bloquean todos los plugins NPAPI, en realidad es a todos excepto a Adobe Flash Player. Un gran número de estudios ha demostrado que Flash es una de las principales fuentes de vulnerabilidades en los sistemas informáticos y que, además, ha sido superado con creces en todos los aspectos por el nuevo estándar HTML5, sin embargo, aún está presente en muchas webs y, por ello, ni Google ni Mozilla se atreven a acabar con su soporte en sus navegadores.

Tarde o temprano este plugin terminará por desaparecer, aunque, mientras eso ocurre, de momento seguirá funcionando en los navegadores, aunque se elimine por completo el soporte para el resto de plugins NPAPI.

¿Aún visitas páginas web con plugins NPAPI?

Compártelo. ¡Gracias!
Continúa leyendo
  • Pingback: Habilita Java y Silverlight en Firefox 52 con este sencillo truco | Esther Claravalls()

  • jmaguiar70

    a mi no me aparece esa entrada

    • ruvelro

      Tienes que instalar la versión ESR 😀

  • Bill Gates

    Otra manera y mas sencilla de seguir usando el Java, es no actualizar el navegador a la version 52 y seguir usando la 51.

    Claro que no es muy recomentable, pero teniendo un buen corta fuegos y antivirus, se puede seguir usando la version 51 sin problema alguno

    • ruvelro

      El problema es usar una versión vieja, como la 51, sin soporte.

  • Juan Martín

    Acabo de actualizar a la versión 52 esr. Supongo que la están lanzando por defecto por el tema de los plugins, porque es la que me ofrecía el actualizador. La entrada “plugin.load_flash_only” ya viene con el valor en “false” por defecto.

  • Juan Quintanilla

    Si defines esa variable a mano en la versión 53 funciona. Lo he visto en un vídeo de youtube, lo he probado y todo ok.