Java SE 6 Update 29 con corrección de varias vulnerabilidades y errores

Escrito por Antonio
Actualidad

Java SE 6 Update 29 es la nueva versión de Java lanzada por Oracle, en la que se corrigen 20 vulnerabilidades de seguridad encontradas. Java es un entorno multiplataforma, puesto que está disponible para todos los sistemas operativos Windows, Linux y Solaris. Conoce a continuación todos los detalles y novedades de esta versión de Java.

Java SE (Standard Edition) se compone de JDK y JRE. Las diferencias entre ambas versiones son:

JRE (Java Runtime Environment): versión recomendada para la ejecución de aplicaciones Java y applets. Recomendada para la mayoría de usuarios.

JDK (Java Development Kit): versión recomendada para desarrollar aplicaciones Java y applets, y además incluye JRE. Recomendada para desarrolladores.

En Java SE 6 Update 29 (1.6.0_29-b11), según muestra Oracle en su listado oficial de cambios, se corrigen 20 vulnerabilidades de seguridad, de las cuales 6 afectan a JRockit, y también se incluyen varias correcciones de errores. Por ello, Oracle recomienda actualizar cuanto antes a esta nueva versión, ya que muchas de ellas podrían explotarse sin necesidad de introducir un usuario y contraseña.

Seguramente alguna vez os habréis preguntado: ¿qué versión de Java tengo instalada? Podéis comprobarlo en este enlace.

Podemos bajar Java SE 6 Update 29 en su versión JRE o JDK desde los siguientes enlaces:

–> Descarga Java JRE 6 Update 29

–> Descarga Java JDK 6 Update 29

Contenidos recomendados:

+ Manuales de seguridad en SoftZone

Compártelo. ¡Gracias!
Continúa leyendo

Comentarios

10 comentarios
  1. AsTrA 20 Oct, 11 14:06

    Me salio esta mañana en cuanto encendí en pc.

    Salu2!!

    0
  2. Anónimo 20 Oct, 11 16:38

    Yo ya lo anctualicé ayer. Mucho tardan en actualizar y para más ya llevo varias versiones y algun mes q ueotro que el plugin java para mozilla firefox es incompatible con las nuevas versiones de java, por ejemplo la actual versión mozilla firefox 7.0.1

    0
    1. Anónimo 20 Oct, 11 17:30

      Es incompatible la Console en el administrador de extensiones pero no es incompatible el Toolkit y Platform en lo que se refiere a Plugins, porque ejecuto programas de Java sin ningún problema en Firefox 7.01.
      Un Saludo

      0
  3. AsTrA 20 Oct, 11 18:24

    He estado trasteando en el panel de control las opciones de java y me he fijado que viene asignado por defecto un 1GB de espacio para los archivos temporales, mi pregunta es si es normal asignar tanto espacio y si no es mejor desactivar la casilla para que no guarde ningun archivo temporal.

    Salu2!!

    0
    1. Antonio 20 Oct, 11 19:39

      Yo también tengo asignado 1 GB (valor por defecto). Puedes bajar el valor (nunca desactivarlo) o pasar CCleaner cada cierto tiempo para borrar basura y ficheros temporales.

      Saludos.

      0
      1. AsTrA 20 Oct, 11 20:59

        Lo dejaremos como esta entonces, de momento tengo espacio en el disco duro. Solamente lo comentaba por que me pareció excesivo 1Gb para los archivos temporales.

        Gracias por comentar!

        0
  4. Alex 21 Oct, 11 15:30

    Cual debería instalarme?

    Java SE Runtime Environment 6 Update 29
    Java SE Development Kit 6 Update 29

    Que diferencia hay entre los 2?

    0
    1. AsTrA 21 Oct, 11 16:19

      Tienes 2 opciones, a no ser que seas desarrollador web la opcion mas aconsejable es la JRE (Esa es la que yo tengo).

      Java SE (Standard Edition) se compone de JDK y JRE. Las diferencias entre ambas versiones son:

      – JRE (Java Runtime Environment): versión recomendada para la ejecución de aplicaciones Java y applets. Recomendada para la mayoría de usuarios.

      – JDK (Java Development Kit): versión recomendada para desarrollar aplicaciones Java y applets, y además incluye JRE. Recomendada para desarrolladores.

      0
    2. Anónimo 21 Oct, 11 16:21

      joer macho te lo explican mascaito en la noticia y lo preguntas……. si la hubieras leido lo sabrias

      0
  5. Anónimo 21 Sep, 15 7:39

    Thanks, this has been puzzling me for a while now, in my case just uptedas (over a dependency issue, which made no sense), but I’d just skip them until now when I couldn’t install something because my Eclipse was too old Thanks for the post, fixed it for me too.

    0