Vulnerabilidad crítica para Apple OS X Leopard

Escrito por Robert Gago
Actualidad
0

Un agujero de seguridad crítico ha sido descubierto para sistemas con OS X Leopard. Esta vulnerabilidad permite a un atacante, tener control total sobre el sistema para realizar cualquier acción, sobre sistemas OS X 10.5 Leopard. El problema radica en el Apple Remote Desktop Agent, que un atacante podría seducir para obtener derechos de administrador. Este componente se halla en OS X 10.4 Tiger y 10.5 Leopard, si bien solo afectaría a este último.

Apple tuvo conocimiento de este agujero anteriormente, concretamente desde el pasado Octubre, resolvió el problema para OS X 10.4, pero volvió a aparecer en OS X 10.5. Apple hace unos días reconoció el problema, pero minimizó las consecuencias y el riesgo de dicha vulnerabilidad. Los expertos por su parte desmienten a la compañía y aseguran que el riesgo es serio, y muy factible para cualquier atacante. A la espera de un parche oficial de Apple, Jay Beale experto en seguridad informática, ha sacado una solución casera para resolver el problema: Copiar y pegar el siguiente texto dentro del Terminal:

osascript -e ‘tell app “ARDAgent” to do shell script “chmod 0555 /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent”‘;

Antes de realizar este proceso debemos advertir, que esta solución es para la versión inglesa de Leopard, y que en la versión española, puede variar la ruta del texto a introducir en el terminal.

Fuente: washingtonpost

Compártelo. ¡Gracias!